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Best Practices
for Using Microsoft
Word to Create
Simple Web Pages

eb development applications like Microsoft FrontPage, Macromedia
Dreamweaver, and Adobe GoLive expedite the process of creating and

editing web pages. These and other programs have become increasingly more
popular and more powerful in their capabilities. However, despite readily available
training and a reasonably gentle learning curve, many educators are still hesitant to
venture into web page design. Perhaps part of the reason is due to the mystique
related to HTML and confusion surrounding the many technologies that intersect in
bringing us the Internet. For users reluctant to venture into web development,
Microsoft Word can be a viable option for someone just beginning to develop
web pages.
 

Microsoft Word has essentially become the standard word processing
application and for good reason; it�s an excellent, general-purpose application for
creating a variety of documents. With the increasing popularity of the Internet,
Microsoft has made progress over time in integrating Word and the other Microsoft
Office applications with the web. By utilizing Microsoft Word, those seeking to
develop simple web pages can begin with a tool and application interface with
which they are already familiar. By following some best practices, perhaps forgetting
a few bad habits, and using various utilities to cleanup the extraneous HTML code
that Word generates, the average user can create simple, static web pages that are
acceptable. However, for more dynamic documents that feature interactive
elements or more sophisticated page layouts, a web development tool like
Macromedia Dreamweaver would be needed.

 
Those using Word for web page development will need to use Word with the

mindset that the ultimate product will be a web page. Web documents are written
in HTML, or Hypertext Markup Language, a document language that defines the
structure and layout of a web document by using a variety of tags and attributes.
While learning how to write HTML code is not necessary for creating web pages, it
is important to understand that there are certain constraints imposed by HTML, and
a user cannot do everything he or she may be accustomed to doing in using the
word processor. Because of the nature of how HTML displays web pages, those
using Word in creating a web page will recognize that there are special ways to
format the content in a document that might be different from what they are
accustomed to doing.
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Simple Web Pages, continued

Getting Started
In beginning a new document, you can either start with a document in Word

format, or an HTML document. Selecting File > NewFile > NewFile > NewFile > NewFile > New opens the window you see
in the screen capture below:

   Figure 1:  C   Figure 1:  C   Figure 1:  C   Figure 1:  C   Figure 1:  Create new documentreate new documentreate new documentreate new documentreate new document

If you know from the start that your document will essentially be a web page
that will not be printed or saved as an Adobe PDF file, it makes sense to begin with
a new Web Page. However, for documents that will likely be printed out, it�s
important to realize that it�s often difficult to print out a web page because you
can�t use page breaks to lay out the pages, and the pages often break in
undesirable places within the document. Therefore, choosing to begin with a blank
Word document is often your best option, provided that you follow best
practices in creating your document, with the understanding that the ultimate
product will be a web page.

There are three layouts that you can select when composing a document in
Microsoft Word: Normal, Web Layout, and Print Layout. To change your screen
layout, use the View menu. When using Word to create a web page, it is best to
work in Web Layout mode, although occasionally you should switch to the other
modes to check the appearance of your document, especially if it will be printed.
Note that in Web Layout view, the margins are close to the edge of the page. When
you�re in Web Layout, the ruler should be removed from the toolbar. The width of
text on your page is dependent upon browser and display settings on the
computer that you are using to view your page. Therefore, having the ruler present
in Web Layout would serve no purpose when creating your web page. To remove
the ruler, go to your View menu and uncheck Ruler.

Forgetting Bad Typing Habits
 OK, now don�t get too defensive. The first step is to honestly look at how

you typically use a word processor. There are several bad habits that will cause
trouble in creating web pages. You may get away with these bad habits in typing
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Simple Web Pages, continued

word processing documents, but this will not be the case in creating web pages!

TTTTTab kab kab kab kab keyeyeyeyey: : : : : Please forget that your keyboard has a Tab key!
                                                                                           
Outside of using it to move from one cell or field to another in a table, form,

or spreadsheet, it has virtually no other purpose in creating a web page document.
Do not use the Tab key to indent paragraphs because HTML clean-up utilities, like
the one included with Dreamweaver, will remove indentation created with the Tab
key.

Formatting Paragraphs
If you need to indent your paragraphs, then use Word�s paragraph formatting

feature. Select FormatFormatFormatFormatFormat >  >  >  >  > ParagraphParagraphParagraphParagraphParagraph, and the window like you see on the right will
open. Open the drop-down list under SpecialSpecialSpecialSpecialSpecial to select First lineFirst lineFirst lineFirst lineFirst line     to indent your
paragraph. Indenting your paragraphs this way will insure that your HTML code will
indent your paragraphs using the text-indent property that is a feature of the
Cascading Style Sheet standard.

         Figure 2:  Paragraph window         Figure 2:  Paragraph window         Figure 2:  Paragraph window         Figure 2:  Paragraph window         Figure 2:  Paragraph window
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Simple Web Pages, continued

Inappropriate use of the Spacebar
Inappropriate use of the Space Bar can get you into trouble when creating

documents destined for the web:  
� Don�t use the Spacebar to indent paragraphs; indent your paragraphs

using the paragraph formatting method described above.

� Never use the Spacebar for aligning text or graphics on the page. Use the
Center tool to center text or images, and use the Increase Indent or the
Decrease Indent to indent entire paragraphs or a list of items. If three page
elements need to be spaced across a page, even on a single line, the user
needs to follow best practice and create a three-column tabletabletabletabletable.  

Inappropriate use of the Enter key
The Return or Enter key can also get you into trouble:

� Very few users are actually guilty of this, but don�t hit the Enter key at the
end of each line like you�re using a typewriter. The Enter key should only be
struck once at the end of each paragraph, unless you are creating a
bulleted or ordered list or inserting blank lines on a page. Allow the lines in
a paragraph to automatically wrap from one line to the next.

� Do not hit the Enter key several times to force text to start on a new page.
Inserting a page break for this purpose will allow you to print your
document the way you desire, without causing your document to look
awful in a web browser because of the extra spaces.

Formatting Issues
Selection of fontsSelection of fontsSelection of fontsSelection of fontsSelection of fonts

  You should use fonts that are common to both the Windows and Macintosh
platforms, and which will be installed on the majority of computers that will be
browsing your web pages. If someone views your page and his or her computer
does not have the font installed, your page will be displayed using the browser�s
default font, which is typically Times New Roman. There are basically two major
types of fonts: serif fontsserif fontsserif fontsserif fontsserif fonts, in which the letters have little serifs or embellishments on
the edge of the type, and sans serif fontssans serif fontssans serif fontssans serif fontssans serif fonts that are simpler and lack the serifs.
Generally speaking, in printed documents, serif fonts are often used for the main
body of text in order to aid in reading and the recognition of characters because
the little serifs help to guide our eyes and our brain, while sans serif fonts are often
used for headings. However, on a computer screen, many people believe that sans
serif fonts are easier to read because serifs tend to disappear on the screen,
especially with small type. The sans serif font Arial is a popular font used for web
pages. Some serif style fonts like Courier NewCourier NewCourier NewCourier NewCourier New are mono-spaced fonts where
spacing is not adjusted to accommodate letters of different sizes (typewriter style
fonts).

 
Regardless of which fonts you use, a general principle for most situations is the

rule that you should never use more than two fonts on the same pageyou should never use more than two fonts on the same pageyou should never use more than two fonts on the same pageyou should never use more than two fonts on the same pageyou should never use more than two fonts on the same page.
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Simple Web Pages, continued

Using too many fonts on a page can be a bit of an eyesore. The text of this article,
for example, is sans serif. While the safest fonts to use are probably Times New
Roman and Arial, there are other fonts that are a relatively safe bet, and which will
be found on most computers. The following table lists fonts that are good for web
pages:

  Figure   Figure   Figure   Figure   Figure 3: F3: F3: F3: F3: Font charont charont charont charont char ttttt

Use Styles
Often, those using Microsoft Word for

word processing will spend a lot of time
highlighting text throughout a document and
manually changing the font and font size over
and over again. There is a better way. Using
StylesStylesStylesStylesStyles allows you to quickly format a
document in such a way that you�re
consistently applying the same font
attributes throughout the document. For
example, let�s assume you want certain sub-
headings to all be the same font and size, in
bold text. Rather than manually having to
make these three changes repeatedly for
each sub-heading, you can use Styles to
simply the process. For example, the title at
the top of a page might be set for Heading
2, section headings might be Heading 4,
while the main body of text is Normal text.

Not only does using Styles save time
and labor for general word processing, but
using Styles is also important for documents
that will later become web pages. When a
document that uses Styles is saved to HTML,
Word will save your document using the
HTML heading tags such as H1, H2 and so
forth. To use the Paragraph styles in Word,
highlight your paragraph or text, and select
Format > StyleFormat > StyleFormat > StyleFormat > StyleFormat > Style, or use the drop-down list
on the Formatting toolbar.

Figure 4: Style selectorFigure 4: Style selectorFigure 4: Style selectorFigure 4: Style selectorFigure 4: Style selector

http://www.vste.org


Spring 2003 Vol. 17, No. 3  34

www.vste.org

Simple Web Pages, continued

Use Bulleted and Numbered Lists and
Decrease and Increase Indent

Use automatically formatted bulleted and numbered lists for both
documents in Word format, as well as web pages. Note that if you start trying to
type a list manually by beginning the first line with 1. (number 1 followed by a
period) and then a space, Word automatically converts your text to a numbered
list. Automatically formatted lists format well when saved in HTML.

Please note what was emphasized above under the sections relating to
inappropriate use of the Tab key and Space Bar. If you want an unordered list
without bullets, then you can type your list of items, highlight the text and use
Decrease Indent or Increase Indent to indent the list of items. If you want a bulleted
list, then simply type your list, highlight the text and create a bulleted list.

When creating bulleted lists, don�t try to get too fancy with the style of your
bullet. Using customized bullet styles relies typically upon the Wingdings font, so that
the computer being used to view your page must have Wingdings installed
(however, most computers will have Wingdings installed).

Use Tables!
Tables are an excellent tool for organizing and displaying information in rows

and columns. As mentioned earlier in the section relating to inappropriate use of
the Tab key, the practice of
typing and using the Tab key
to manually move over a set
amount of space for each
column is not best practice
(unless you�re using an old
typewriter that you happen
to pick up from an antique
store).

Those creating web
pages must become
proficient with tables
because web page layout is
typically highly dependent
upon effective use of tables.
Word provides you with
some decent tools for
creating tables. There are
generally two main ways to
create tables in Word:

Use the Use the Use the Use the Use the TTTTTableableableableable menu to inser menu to inser menu to inser menu to inser menu to inser t a tablet a tablet a tablet a tablet a table
You can select TTTTTable > Inserable > Inserable > Inserable > Inserable > Insert > Tt > Tt > Tt > Tt > Tableableableableable to create a table and specify the

number of columns and rows.
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Draw Tables
You can draw a

table using the Tables
and Borders button on
the Standard toolbar.

While drawing
tables is an easy way
to create tables, there is a serious drawback if you�re creating tables for a web
page with this method. When you draw tables, Word, of course, creates a table
with the exact dimensions that you drew. However, tables that are drawn do not
automatically scale very well in the web browser to suit different display settings.  In
most cases it is best NOT to draw tables, or even overly �tweak� the height of rows
or the width of columns. While sometimes you will need to adjust the height of rows
or the width of columns, leaving these settings undetermined will allow a table to
automatically scale to suit different display settings and whatever content is placed
in the table. Therefore, our focus will be on using the Table menu to create tables
and on becoming proficient with ways to customize tables and edit their
properties.

Table Properties
After

you create
your table,
it is easy to
adjust the
properties
of the table.
Place your
cursor
anywhere
within the
table, and
select Table
> Table
Properties.
The best
way to learn
how to
create
tables is just
to do it.
Create a
practice
document
and
experiment

Simple Web Pages, continued

Figure 6: TFigure 6: TFigure 6: TFigure 6: TFigure 6: Table draw toolbarable draw toolbarable draw toolbarable draw toolbarable draw toolbar

Figure 7: TFigure 7: TFigure 7: TFigure 7: TFigure 7: Table properable properable properable properable proper ties (table tab)ties (table tab)ties (table tab)ties (table tab)ties (table tab)
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with creating different tables and changing properties. In the screen capture on the
right, notice you can change the properties of the table as a whole, or the
properties for a row, column, or even an individual cell.

Changing Cell Properties
Knowing how to change the Vertical Alignment of a cell is something that will

be useful in formatting your table. In this particular cell, the vertical alignment is set so
that the text starts at the top of the column.

          Figure 8: TFigure 8: TFigure 8: TFigure 8: TFigure 8: Table properable properable properable properable properties (cell tab)ties (cell tab)ties (cell tab)ties (cell tab)ties (cell tab)

Using Horizontal Lines
To add a horizontal line to your document, select FFFFFororororormat > Borders andmat > Borders andmat > Borders andmat > Borders andmat > Borders and

ShadingShadingShadingShadingShading, and then click on the button on the Borders tab.

This opens the Horizontal Line window, seen in the screen capture. Please
note that all of the options on the PicturesPicturesPicturesPicturesPictures tab use images for the horizontal lines,
except for the first option. Choosing the first option allows you to create a
horizontal line without adding additional download time to your document
because Word takes advantage of the horizontal rule <HR> tag in HTML for this
particular option.

Simple Web Pages, continued
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        Figure 9: Horizontal line window        Figure 9: Horizontal line window        Figure 9: Horizontal line window        Figure 9: Horizontal line window        Figure 9: Horizontal line window

Inserting Image Files
Pictures FPictures FPictures FPictures FPictures From Filerom Filerom Filerom Filerom File

There are several ways to add images to your documents in Microsoft Word.
You may have existing image files that you�d like to add, in which case you simply
select InserInserInserInserInsert > Picture > Ft > Picture > Ft > Picture > Ft > Picture > Ft > Picture > From File rom File rom File rom File rom File and browse to the location on your drive
where the file is stored,
and then select the file
and click on the Insert
button.

When you later
save your page in HTML
format, you�ll need to
remember to copy both
your web page file as well
as image files when you
copy the page to
another drive, computer,
or web server.

Simple Web Pages, continued

 Figure 10: Inser Figure 10: Inser Figure 10: Inser Figure 10: Inser Figure 10: Inser t pic windowt pic windowt pic windowt pic windowt pic window
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Copy and pasting images
Virtually any image that you copy to the Windows clipboard can be pasted

into your Word document. When you later save your document in HTML format,
Word creates a special folder for image files and assigns a file name to each of the
individual images on the page. For example, this particular document was saved
using the file name word_for_web_pages.htm, and Word automatically created a
folder entitled word_for_web_pages_files to house the images that are
embedded in the document.

Using the Microsoft Clip Art Gallery
You can also use the Microsoft Clip Art Gallery to add images to your page,

by selecting InserInserInserInserInsert > Picture > Clip Art > Picture > Clip Art > Picture > Clip Art > Picture > Clip Art > Picture > Clip Arttttt. The gallery features a search function
that works very effectively. For example, assume you were searching for an image
to accompany a hyperlink that you�re providing for visitors, so they can contact
you by e-mail. Depending upon how many images are installed on a particular
computer, using the search function to search for the keyword �e-mail� or �mail� will
probably find several images of envelopes or mailboxes.

Saving Your Document and the Microsoft
Office 2000 HTML Filter

The first section in this document, Getting Started, discussed that in beginning
a new word processing document you can either start with a document in Word
format or an HTML document.  If you opt to create a document in Word format, it is
easy to convert your document to HTML format. Simply choose File > Save AsFile > Save AsFile > Save AsFile > Save AsFile > Save As
and open the drop-down list for Save as type. Choose Web Page for the file type,
as seen in the following screen capture.

            Figure 11: Save as window with .html highlightedFigure 11: Save as window with .html highlightedFigure 11: Save as window with .html highlightedFigure 11: Save as window with .html highlightedFigure 11: Save as window with .html highlighted

DO NOT include any spaces in the file names of web pages or accompanying
image files. You can use an underscore to separate parts of a file name, but do not
use spaces.

If you save a Microsoft Word document in HTML and examine the source
code generated by Word, you will notice that there are special Office-specific
markup tags embedded in the code. These tags are designed to assist with the
�round-trip� of a document from HTML format back to Word format. Before
beginning to create word documents with Office 2000, it is recommended that
you download and install the Microsoft Office 2000 HTML filter, available on
Microsoft�s web site: http://office.microsoft.com/downloads/2000/Msohtmf2.aspx

Simple Web Pages, continued
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This special filter is free, and it allows you to save your document and remove
the Office-specific tags. Removing these Office tags from the code makes your
document more compact and more HTML compliant, and you reduce the file size
of a document, thereby saving on storage space on your hard drive or web server.
The Office 2000 HTML filter also adds the Copy as HTMLCopy as HTMLCopy as HTMLCopy as HTMLCopy as HTML feature as on option
under the Edit menu.

Using the Office 2000 HTML Filter
To export a document using the Microsoft Office 2000 HTML filter, simply

choose File > ExporFile > ExporFile > ExporFile > ExporFile > Export Tt Tt Tt Tt Tooooo and choose Compact HTML.

            Figure Figure Figure Figure Figure 12: Expor12: Expor12: Expor12: Expor12: Export tot tot tot tot to

Microsoft Word and Macromedia
Dreamweaver

While the Microsoft Office 2000 HTML Filter does a pretty good job of
cleaning up Office-specific HTML code , the professional web development
product
Macromedia
Dreamweaver
includes a similar
utility that
performs much
the same
function. After
opening
Dreamweaver,
select File >File >File >File >File >
ImporImporImporImporImpor t >t >t >t >t >
WWWWWord HTMLord HTMLord HTMLord HTMLord HTML
and browse to
select and open
your Word
document.
Dreamweaver�s
import utility

Simple Web Pages, continued

    Figure 13: Clean up word HTML    Figure 13: Clean up word HTML    Figure 13: Clean up word HTML    Figure 13: Clean up word HTML    Figure 13: Clean up word HTML
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opens a window that allows you to choose the version of Microsoft Word for the
document and the specific items that you�d like to clean up.

Experiment with Macromedia Dreamweaver and you�ll quickly see that the
application provides a treasury of features and advanced capabilities far beyond
what Microsoft Word offers for web development.

However, for simple web pages, Microsoft Word can be a viable option for
someone just getting started. By using the tool with the mindset and requisite skills
that the ultimate product will be a web page, you will find that Microsoft Word will
allow you to create simple web pages that are nicely formatted.

� Convert Word to HTML with Minimal Baggage!
http://www.delta.edu/emptrain/bookworm/word2html.html

� Converting Word Files to HTML
http://web.pdx.edu/~bowersn/basics/word_to_html.html

� Converting Word to HTML
http://www.yale.edu/instruct/web/html_info/word_to_html.htm

� Word 2000 Tutorial
http://www.fgcu.edu/support/office2000/word/web.html

� Building a Web Page with Microsoft Word 97
http://html.miningco.com/library/beginning/bl_begin070399.htm

Mark D. Webster is a specialist for Instructional and Information Technology
at the Mathematics & Science Center in Richmond, Va. He can be reached
at: mwebster@mathscience.k12.va.us.
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